Quantcast

Sublimox users only

Beekeeping Forum

Help Support Beekeeping Forum:

B

Beefriendly 

Guest
Thread resurrection....

Are you sure about the 3mm tube diameter?
I have some 28mm x 3mm viton o rings and the fit of the nylon cup now feels loose in comparison to the original. I have yet to use the sublimox with them on though so all may well be well.
To the eye the new rings look smaller as well. I have vernier calipers at work but that's not until January now.
Thanks for any help.
Yes they work fine. When your sublimox heats up the "looseness" disappears. They seem more robust as I've yet to break the first ones I put on over 2 years ago...and it gets used a lot.
Abelo also sells the "genuine" sublimox sealing rings if the looseness is still an issue with the type of rings you have....But try turning your sublimox on (plus cap and ring) first.
 
Last edited:

Apiarisnt 

House Bee
Joined
May 1, 2016
Messages
249
Reaction score
15
Location
Herefordshire
Hive Type
14x12
Number of Hives
8
Another two years have gone by, so time to resurrect this thread.

My Sublimox is beginning to show symptoms in emulation of the Challenger rocket problem, so I have been in search of replacement O rings. I have ordered some 28mm ID x 3mm thick Viton ones from here:


£7.23 for 10 including free first class postage.

I will report back if there are any issues, or if I have got it wrong
 

Apiarisnt 

House Bee
Joined
May 1, 2016
Messages
249
Reaction score
15
Location
Herefordshire
Hive Type
14x12
Number of Hives
8
Another two years have gone by, so time to resurrect this thread.

My Sublimox is beginning to show symptoms in emulation of the Challenger rocket problem, so I have been in search of replacement O rings. I have ordered some 28mm ID x 3mm thick Viton ones from here:


£7.23 for 10 including free first class postage.

I will report back if there are any issues, or if I have got it wrong

  • Good news: Stunningly quick delivery
  • Bad news: They sent 28mm x 2mm
  • Good news: They accepted eBay return request instantaneously

Will continue the saga as it unfolds...
 

MJNT 

Joined
Apr 10, 2018
Messages
5
Reaction score
3
Location
Lancashire
Hive Type
none
Advice from anyone with electrical expertise please . why does the setup I am using not work? I am using a novo GB70 car jump starter then an inverter to get 240v ac. And then a sublimox. When I turn on the inverter the sublimox green light comes on but as soon as the amber light comes on the sublimox cuts out anc the inverter error light comes on on . It works fine when I plug the sublimox directly into the mains ( utility room filled with sublimated oxalic acid from remnants left testifies to that!)
 

MJNT 

Joined
Apr 10, 2018
Messages
5
Reaction score
3
Location
Lancashire
Hive Type
none
Is the inverter rated for the power used by the sublimox?
Thanks solved it!! Don’t think the starter was charged en must be faulty charging indicator light. Charged it overnight even though it looked fully charged and now all is we. Thank you anyway
 

MJNT 

Joined
Apr 10, 2018
Messages
5
Reaction score
3
Location
Lancashire
Hive Type
none
Thanks solved it!! Don’t think the starter was charged en must be faulty charging indicator light. Charged it overnight even though it looked fully charged and now all is we. Thank you anyway
Not we .... well
 

Latest posts

Top